composer报错Class Fxp\Composer\AssetPlugin\Repository\NpmRepository does not exist

要安装yii2,先装了Composer,composer装好后,按照官网的步骤,执行

php composer.phar global require
“fxp/composer-asset-plugin:~1.1.1”

但是报错了  Class
Fxp\Composer\AssetPlugin\Repository\NpmRepository does not exist

这是由于一个api更新了,需要执行以下命令就OK了

php composer.phar global update
fxp/composer-asset-plugin –no-plugins

分类:

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注